The MariaDB project is pleased to announce the immediate availability of the following new stable (GA) MariaDB versions:

Security Updates

These releases are “bug fix” releases and they include, among other things, fixes for the following security vulnerabilities:

New Packages

MariaDB 5.5.29 includes packages for Fedora 18 “Spherical Cow” and Ubuntu 12.10 “Quantal Quetzal”. Visit the Repository Configurator to generate the necessary commands to easily install MariaDB on these and many other distributions.

We’ve also extended the repository configuration tool to provide instructions for distributions which include MariaDB. We’ve started with Mageia and will be adding others soon.

Discontinued Builds

Along with the news of new package builds is the news that some old distributions will be deprecated. The MariaDB project tries to support as many different operating systems and Linux distributions as possible. However, when a distribution or OS stops receiving upstream security and other updates it becomes difficult to provide packages for that platform. In such cases, our policy is to deprecate that platform and stop building binary packages for it in our build system.

As of 1 Feb 2013, we will stop building and testing packages for the following:

  • Fedora 16 “Verne”
  • Debian 5 “Lenny”
  • Ubuntu 10.10 “Maverick”
  • Ubuntu 11.04 “Natty”

Even after your chosen Linux distribution is deprecated, packages and support are still available. Companies such as SkySQL and Monty Program (among others) provide paid support for all versions of MariaDB and back to even very old MySQL versions. This includes packaged binaries.

More information on our deprecation policy can be found on the MariaDB Deprecation Policy page.

Archived Releases

From the beginning of the MariaDB project in 2009 we’ve kept all of our old releases online via our network of mirrors. Doing this is great for those few who are interested in old releases, but the disk space required to host all of our old releases is over 130 Gigabytes at present and grows by several gigabytes with each new release. This is too much for some of our mirrors to handle. So, starting with this round of releases our primary mirror will only host the most recent few releases in each series (5.5, 10.0, 5.3, and so on). Mirrors are, of course, free to keep archiving every release, but the primary mirror that they pull from will not.

Old releases do have value, so for those that are interested in old releases, we are setting up a simple, no frills, archive server which will host them. Once the server is up and running, links to archived releases on https://downloads.mariadb.org will point at the archive server. During the transition period, links to some old releases may disappear for a short time, but don’t worry, they haven’t been deleted, they’re just being moved!

If you have hundreds of spare gigabytes on a fast connection and would also like to host the complete MariaDB archive, contact us at mirror at mariadb.org and we’ll include a link your mirror from our archive server. (see Mirroring MariaDB for more information about becoming a mirror).

User Feedback plugin

MariaDB includes a User Feedback plugin. This plugin is disabled by default. If enabled, it submits basic, completely anonymous MariaDB usage information. This information is used by the developers to track trends in MariaDB usage to better guide development efforts.

If you would like to help make MariaDB better, please add “feedback=ON” to your my.cnf (my.ini on Windows) file!

See the User Feedback Plugin page for more information.

Quality

The project always strives for quality, but in reality, nothing is
perfect. Please take time to report any issues you encounter at:

http://mariadb.org/jira

We hope you enjoy MariaDB!

  • Pingback: Обновление MariaDB 5.5.29, 5.3.12, 5.2.14 и 5.1.67 с устранением уязвимостей | AllUNIX.ru — Всероссийский портал о UNIX-системах

  • jenino

    Can’t download mariadb-5.5.29-winx64.msi. –> “Redirection is only allowed to valid mirrors”

    • http://daniel-bartholomew.com/ Daniel Bartholomew

      Sounds like one of the mirrors is misbehaving, which mirror are you using?

      • jenino
        • http://daniel-bartholomew.com/ Daniel Bartholomew

          Ahh, ok. That mirror was recently turned off. Select a different mirror from the list on the right-side of the page (towards the bottom) and you should be good to go.

          • jenino

            ah sorry. didn’t notice the mirror list. downloading now. thanks daniel.

  • http://www.0xbaadf00d.com/ Thibault

    There is still no update available in the repository of Debian 7 Wheezy. When will it be released?

    • http://daniel-bartholomew.com/ Daniel Bartholomew

      That’s strange. It should be there. What are your sources.list settings for MariaDB?

      • http://www.0xbaadf00d.com/ Thibault

        I use this repo:

        deb http://ftp.igh.cnrs.fr/pub/mariadb//repo/5.5/debian wheezy main

        • http://daniel-bartholomew.com/ Daniel Bartholomew

          When I use the http://ftp.igh.cnrs.fr repo in my sources.list it appears 5.5.29 is there:

          daniel@gandalf:~$ apt-cache show mariadb-server
          Package: mariadb-server
          Source: mariadb-5.5
          Version: 5.5.29-mariadb1~wheezy

          daniel@gandalf:~$ apt-cache show mariadb-server-5.5
          Package: mariadb-server-5.5
          Source: mariadb-5.5
          Version: 5.5.29-mariadb1~wheezy

          • http://www.0xbaadf00d.com/ Thibault

            oh, excuse me, I forgot to tell you that I installed the “mariadb-galera-server” package.
            This version is still in alpha, updates should come later. Thank you for your help;

            08:56:39-root@mariadb-galera-1:~$ apt-cache show mariadb-galera-server
            Package: mariadb-galera-server
            Source: mariadb-5.5
            Version: 5.5.28-mariadb-a1~wheezy
            Architecture: all
            Maintainer: MariaDB Developers

          • http://daniel-bartholomew.com/ Daniel Bartholomew

            Ok, that makes more sense. :)

            The mariadb-galera-server package is still at version 5.5.28. It will be updated to 5.5.29 soon. I’m hoping that it will be in the next week or so, but I’m not sure of the exact time frame.

          • http://www.0xbaadf00d.com/ Thibault

            thanks